Nieuwe Raspberry Pi Camera en Astrofotografie

astrobry

Sedna
Ik merk nu met de allsky dat de beelden tijdens de nacht maar telkens om de 3 minuten (+30sec) worden genomen, terwijl de belichtingstijd op 30 sec staat ingesteld. In de camera settings staat de tijd tussen elk beeld op 10 msec ingesteld. Enig idee wat de oorzaak zou kunnen zijn ? Ik vind niet direct nog andere settings die hiermee te maken hebben.
 

RobRob

Donateur
Heb je sudo rpi-update gedaan, je hebt de laatste firmware en raspistill versie namelijk nodig om dit te laten werken...
 

astrobry

Sedna
Heb je sudo rpi-update gedaan, je hebt de laatste firmware en raspistill versie namelijk nodig om dit te laten werken...

Ja, dat had ik een 5-tal dagen geleden uitgevoerd en dan de allsky git opnieuw geïnstalleerd. Maar ik kan het nog eens herhalen.
 

thex

Black hole
Hoi RoboRob

De ascom driver ga ik zeker proberen, maar ik heb wel een vraag over de allsky software aanpassing. Bij mij is het beeld veel te veel rood. Als ik echter raspistill gebruik, krijg ik een normaal beeld. De image instelling auto wb en wegnemen van de roodcorrectie laten geen verschil zien (na reboot). Is hier wat aan te doen ?

Tweede vraag: voor een timelapse had ik meerdere images in opslag verwacht. Bij gebeurt dat niet. De image folder was ook niet aangemaakt (heb ik met de hand gedaan). Moet ik script allsky_mfs.sh nog draaien ?

RP pi versie 4b, meest recente noobs en alles bijgewerkt. Op versie 3 doet de camera het niet bij mij, en op 2 weer wel ???

20-7-2020: de ontbrekende images zijn opgelost. Vanaf ongeveer 2 uur vannacht werden die aangemaakt. Het filesysteem is echter wel vol gelopen nu,
Ook heb ik de image settings elders gevonden (niet afkomend van de gui). Helaas de witbalans nog niet opgelost.
 
Laatst bewerkt:

RobRob

Donateur
Kan je de blauw en rood waardes aanpassen en dan de service stoppen en starten? helpt dat? zo niet doe dan even het volgende:

ga via ssh naar de Pi en type:

cd ~/allsky
./stopallsky.sh
./allsky_RPiHQ.sh


Kan je de output inclusief het aangeroepen raspistill commando even copy & pasten en in een posting stoppen (of naar mij PM-en). Dan kunnen we even kijken of er iets mis gaat.

Je kan met <CTRL> C het script afbreken en de AllSkyCam service weer starten met:

./startallsky.sh
 

RobRob

Donateur
Ja, dat had ik een 5-tal dagen geleden uitgevoerd en dan de allsky git opnieuw geïnstalleerd. Maar ik kan het nog eens herhalen.

Kan je me je /etc/raspap/settings.json sturen (of in een rpy op dit draadje posten?

Graag ook het volgende uitvoeren Ga via ssh (terminal) naar de Pi en type:

cd ~/allsky
./stopallsky.sh
./allsky_RPiHQ.sh


Kan je de output inclusief het aangeroepen raspistill commando even copy & pasten en in een posting stoppen (of naar mij PM-en). Dan kunnen we even kijken of er iets mis gaat.

Je kan met <CTRL> C het script afbreken en de AllSkyCam service weer starten met:

./startallsky.sh
 

RobRob

Donateur
Hoi Thex,

Je hebt de white balance op auto staan dus dan bepaald de camera de wit-balanse maar daar kan hij 's nachts niet zo goed mee overweg. Zet de Auto White Balance uit en stel de volgende waardes in: rood 2.8 en blauw 2.
Probeer het dan vannacht nog een keer... Maak vannacht ook even een dump zoals je die zojuist gemaakt hebt zodat we kunnen kijken of het dan wel goed gaat qua aanroep van het raspistill commando.

Als je de Angle op 0 (of zelfs op een positieve waarde) zet begint de nacht wat eerder ;-) maar zijn de foto's in het begin wel overbelicht maar kan je wel eerder testen of de sluitertijd overeenkomt met je verwachtingen...
 

thex

Black hole
Ga ik doen. Alleen in de originele settings staat de white balance op uit, rood op 2.8 en blauw op 2. En daarmee had ik ook een rood beeld. Ik neem aan dat ik het bestand in etc/raspap/settings.json moet aanpassen ?
 

RobRob

Donateur
Als je de GUI gebruikt kan je het gewoon in de GUI onder de menu optie Camera Settings deze aanpassen en bewaren en dan de AllSky service stoppen en starten op het tab blad System. Als je niet de GUI hebt geïnstalleerd dan in de ~/allsky/settings.json file de AWB uitzetten en de kleurinstellingen aanpassen.
 

RobRob

Donateur
Weer wat zaken toegevoegd aan de HQ camera versie van de AllSkyCam software:

– automatisch software upgrades

– dark frame creatie en processing

– tekst annotaties

– auto focus switch

Om te handmatig te upgraden:

cd ~/allsky; git pull; make; sudo cp camera_options.json /etc/raspap
 

nop

Admin
Inmiddels ook deze fish eye lens van Aliexpress binnen en een dome. Nu wat knutselen en kijken of ik de handel goed en stabiel in focus houd.
 

Bijlagen

  • Screenshot 2020-09-01 at 10.39.52.png
    Screenshot 2020-09-01 at 10.39.52.png
    827,5 KB · Weergaven: 3

MichelB

Michel
Ondertussen is het werk van RobRob opgenomen in de versie van Thomas Jacquin :goedgedaan.

Wat niet duidelijk op de GitHub pagina staat is dat je in config.sh handmatig de juiste camera moet instellen.
CAMERA="RPiHQ" of CAMERA="ZWO"

Ik krijg het overigens niet voor elkaar om de afbeeldingen met SFTP op een website te krijgen. In ftp-settings.sh gebruik ik dezelfde gegevens als in FIleZilla, daarmee kom ik wel op de website, maar niet met de allsky software. Iemand enig idee? Of is er ergens een logbestand waarin ik kan ziet waar het mis gaat?
 
Laatst bewerkt:

MichelB

Michel
Dat kan ik, username vind ik niet zo spannend. De site is gehost bij strato, daar is (in mijn geval) de username tevens de site URL.

#!/bin/bash

# FTP/SFTP settings
PROTOCOL='sftp'
USER='bovenonshuis.nl'
PASSWORD='@@@@@@@'
HOST='ssh.strato.com'
IMGDIR='/allsky/'
MP4DIR='/allsky/videos/'
KEOGRAM_DIR='/allsky/keograms/'
STARTRAILS_DIR='/allsky/startrails/'
 

RobRob

Donateur
ik vraag me af of image dir niet /allsky/images/ moet zijn en dat bij de andere drie er ook niet images tussen moet staan...
 

MichelB

Michel
Ik heb het aangepast. Is er een manier om het direct te testen ipv wachten tot het donker wordt. Bv door in config.sh "CAPTURE_24HR=false" op true te zetten?

Ik zou verwachten dat dat werkt want onderstaande heb ik in config.sh ingesteld:
# Set to true to upload current image to your website
UPLOAD_IMG=true
 
Bovenaan Onderaan